Jump to content


Photo

Floating point error


  • Please log in to reply
2 replies to this topic

#1 johmak

johmak

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 24 November 2015 - 10:54 AM

Hi!

 

I have an issue with my Phoenix Winnonlin ASCII model. Here's my differential equations: 

 

DZ(1)= -KA*Z(1)

DZ(2)=KA*Z(2) - KEL*Z(2)

DZ(3)=Constant *( 1 - ( 0.954 *  IC50**Hill / ( (Z(2)/V*fu)**Hill + IC50**Hill ) ) ) - Constant*Z(3)

 

I get error message "Processing halted due to floating point error: INVALID NUMBER" when I use this hill parameter (temporary variable) and rational numbers such as 0.7 , 2.3 etc. There's also same error message when using simulation mode. Already I have resolved that simulation and parameter estimating work if I use whole number 0,1,2,3,4....

 

I have also other differential equations with exponent (used decimal numbers) but these work properly.

 

best regards

 

MH



#2 Simon Davis

Simon Davis

    Advanced Member

  • Administrators
  • 1,166 posts

Posted 07 December 2015 - 03:25 PM

Hi ? Johanna,

 

   I'm not sure I can answer your question without seeing your data or at least some subset of it, maybe parametising with dose and conc values standardised to a common unit would help e.g. if conc was ug/mL and dose was 10 mg then enter 10000ug.

  Also the WNL classic engine is old and particularly for custom models I think you will have more success with PML in the Phoenix model engine, have yout tried your model in that?

 

 Simon.



#3 geetjaan

geetjaan

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 29 April 2021 - 01:18 PM

This is my first time I visit here. I found such a large number of engaging stuff your blog, particularly its exchange. From the huge amounts of remarks on your articles, I surmise I am by all account not the only one having all the relaxation here! Keep doing awesome. I have been importance to compose something like this on my Jaipur Escorts site and you have given me a thought.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users