Jump to content


Photo

PHOENIX MODEL WRITING observation compartment


  • Please log in to reply
8 replies to this topic

#1 Angus McLean

Angus McLean

    Advanced Member

  • Members
  • PipPipPip
  • 223 posts

Posted 17 January 2017 - 09:24 PM

Some time ago I was trying to learn Phoenix models using pml language:  I have revisited this topic today and I am having difficulty with my earlier work.  When inserting an observation compartment it should connect with the central compartment with an arrow so that it is evident that the observations being made on the central compartment.  My approach has been to work with very simple models that I have already run in the classic models.

 

The specific example I attach is for a 1 cpt model with a lag time; first order elimination and first order absorption of 20mg drug.   I do not know to  include the observation compartment. I am planning a "simple" fitting

 

 

 

 

Advice is most welcome;

 

Angus

Attached Files



#2 bwendt@certara.com

bwendt@certara.com

    Advanced Member

  • Administrators
  • 188 posts

Posted 18 January 2017 - 09:27 AM

Angus,

 

you need to connect your Observation block with the central compartment. For this you need to hover over the central compartment until you see the C-connector:

 

CObs1.png

 

Click with left mouse button on this connector and draw a line to the connector on the Observation block:

 

CObs2.png

 

That should fix this problem.

What I noted for the Observation block was that you have checked on the BQL box. You need to uncheck this box since your input data does not contain any information about measurements being censored.

 

CObs3.png

 

Another thing you would need to correct is the Tlag parameter. You have inserted this parameter but you need to connect this with the Absorption compartment:

 

CObs4.png

 

Final thing you need to change is the flow between central and elimination compartment. You need to change from Clearance to Micro parametrization:

 

CObs5.png

 

Please see attached project where I just added an NCA object to get to initial estimates.

 

Attached File  ORAL SOLUTION_bw.phxproj   390.31KB   342 downloads

 

 

Bernd

 



#3 Simon Davis

Simon Davis

    Advanced Member

  • Administrators
  • 1,115 posts

Posted 18 January 2017 - 10:42 AM

Hi Angus, linking compartments is very easy as per the two screen shots I attach below.

 

 

However once i did that there was still something peculiar with your model, after a while I realised you had mixed parametisation.

 

 

I would suggest an easier way to learn how to use the graphical builder is to try the 'set WNL model' button as I did inthe second model here.  then you will get the graphical model built correctly and can track throught the changes from there.

 

  Simon.Attached File  ORAL SOLUTION_saad.phxproj   517.99KB   177 downloadsAttached File  ORAL SOLUTION_saad.phxproj   517.99KB   177 downloads

Attached Thumbnails

  • conn_CObs1.jpg
  • conn_CObs2.jpg
  • parametisation.jpg


#4 Angus McLean

Angus McLean

    Advanced Member

  • Members
  • PipPipPip
  • 223 posts

Posted 18 January 2017 - 02:51 PM

Angus,

 

you need to connect your Observation block with the central compartment. For this you need to hover over the central compartment until you see the C-connector:

 

attachicon.gifCObs1.png

 

Click with left mouse button on this connector and draw a line to the connector on the Observation block:

 

attachicon.gifCObs2.png

 

That should fix this problem.

What I noted for the Observation block was that you have checked on the BQL box. You need to uncheck this box since your input data does not contain any information about measurements being censored.

 

attachicon.gifCObs3.png

 

Another thing you would need to correct is the Tlag parameter. You have inserted this parameter but you need to connect this with the Absorption compartment:

 

attachicon.gifCObs4.png

 

Final thing you need to change is the flow between central and elimination compartment. You need to change from Clearance to Micro parametrization:

 

attachicon.gifCObs5.png

 

Please see attached project where I just added an NCA object to get to initial estimates.

 

attachicon.gifORAL SOLUTION_bw.phxproj

 

 

Bernd

Bernd:  Thank you for the detailed instructions.  I am able to repeat and understand your work.   The initial estimates I obtained by first running the model in classic WinNonlin.  However there is one aspect that troubles me.  When I click on initial estimates I do see the initial estimates I entered, but there is no chart appearing. The windows is blank.  In your work there is the basis of a chart calculated from the initial estimates in the window.   Please can you direct me to getting this chart to appear.   I attach my file



#5 Angus McLean

Angus McLean

    Advanced Member

  • Members
  • PipPipPip
  • 223 posts

Posted 18 January 2017 - 03:27 PM

Bernd: Thank you for the detailed instructions. I am able to repeat and understand your work. The initial estimates I obtained by first running the model in classic WinNonlin. However there is one aspect that troubles me. When I click on initial estimates I do see the initial estimates I entered, but there is no chart appearing. The windows is blank. In your work there is the basis of a chart calculated from the initial estimates in the window. Please can you direct me to getting this chart to appear. I attach my file

Attached Files



#6 Angus McLean

Angus McLean

    Advanced Member

  • Members
  • PipPipPip
  • 223 posts

Posted 18 January 2017 - 03:40 PM

Simon: Please can you point me to the location of the button mentioned below. I do like your suggestion, but right now I cannot see where it is. I am sure I have seen it in the past.<br /><br /><br />I would suggest an easier way to learn how to use the graphical builder is to try the 'set WNL model' button as I did.<br /><br />Angus



#7 Simon Davis

Simon Davis

    Advanced Member

  • Administrators
  • 1,115 posts

Posted 18 January 2017 - 03:58 PM

Angus, I cleaned up the thread a bit where there were some redundnant posts.

 

Below are the screen shots of how to set_wnl model, you must be in in 'built-in' ie. not graphical or textual mode to see this on the Structure tab.

 

And also how to get a Inital estimates chart to display C vs time.

 

remember if you change your model or mappings you should click away from this tab and back again to re-build it.

 

 Simon.

 

Also remember there is an edit button to enable you to add things to an existing post

Attached Thumbnails

  • C_vs_time.jpg
  • set_WNL.jpg

Edited by Simon Davis, 18 January 2017 - 03:59 PM.
example of an edit.

  • Angus McLean likes this

#8 Angus McLean

Angus McLean

    Advanced Member

  • Members
  • PipPipPip
  • 223 posts

Posted 18 January 2017 - 05:01 PM

Thanks Simon: Set WNL under the structure tab is not offered as an optional tab ; the other two options are offered as tabs. In other words there are only 2 tabs visibly offered (Edit as graphical or edit as text) I wonder if that means we I am already in WNL?<br /><br />Angus<br /><br />



#9 Simon Davis

Simon Davis

    Advanced Member

  • Administrators
  • 1,115 posts

Posted 18 January 2017 - 08:28 PM

Sorry Angus, these are buttons not tabs and it's not really possible the 'set WNL' button is not visible, depending on your screen resolution, it may be more to the left above 'statements'.  Please look again and if you cna't find it send a screen shot.

 

However if you were already 'inside' this option then you would not see the 'Edit as graphical' or 'Edit as text' buttons at all but instead the options below where one you had chosen your 'WNL model' you would click apply and return to the 'default' view

 

  Simon

Attached Thumbnails

  • set_WNLapply.jpg





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users