Jump to content


Photo

Using bootstrap in Pirana

bootstrap

  • Please log in to reply
4 replies to this topic

#1 zshen

zshen

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 10 October 2019 - 10:05 PM

Dear all,

I just sent out a ticket to Certara support but later found this useful forum on technical discussions on Pirana and other Certara products.

 

When I tried to test use of bootstrap in pirana, per the instruction, I click on model diagnosis then bootstrap, used the default command:

bootstrap -samples=50 -threads=4 -dir=bs_run6 run6.mod

(run6.mod is my control file. It is actually the control PK file that Pirana founder Ron Keizer used for ACOP training back to a few years ago. with the data file as acop.csv.) 

 

It immediately gave me an error:

fatal error: cannot open file: '50/bootstrap.r'  no such file or directory

 

I can run psn for VPC or NPC successfully but not bootstrap, suggesting installation of Pirana seems fine. Wonder what happen to my installation. I googled but could not find that bootstrap.r is needed for Pirana.

 

It may be just a no-brainer question thus appreciate anyone familiar with Pirana can help on this. 

 

Thank you!

 

Zancong



#2 zshen

zshen

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 11 October 2019 - 04:30 PM

Update: I received response from Pirana, that this is a conflict in the path between phoenix and PsN. In brief, when phoenix winnonlin is installed, it adds its path on top of PsN path (and other paths), therefore Pirana is stuck in looking for a bootstrap.r file (which does not exist in Pirana) when I execute PsN. Per the instruction I moved Phx path to the end of all paths. It works well right away. This can be done by modifying the environmental variables in the advanced system setting in control panel. Here is a link they provided. 

https://www.howtogee...nd-line-access/

 

I believe users having both PHX and Pirana installed may experience similar situation. Certara says until this conflict gets resolved in a forthcoming version of Phoenix this change needs to be done by the user.

 

Thanks,

 

Zancong



#3 Simon Davis

Simon Davis

    Advanced Member

  • Administrators
  • 1,111 posts

Posted 24 October 2019 - 09:01 PM

Zancong, which version of Phoenix are you using because I am pretty sure this was addressed in the 8.2 release?

 

thanks.

 

  Simon.



#4 zshen

zshen

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 24 October 2019 - 09:07 PM

PHX 8.1 is what I installed since early this year. This includes PHX Winnonlin 8.1 to my understanding. 

zancong



#5 Simon Davis

Simon Davis

    Advanced Member

  • Administrators
  • 1,111 posts

Posted 24 October 2019 - 09:09 PM

OK, when you get the opportunity you may upgrade to 8.2 that was released in the summer, there is no charge to upgrade.  I was just checking you weren't reporting the issue with the latest version.

 

 Simon.







Also tagged with one or more of these keywords: bootstrap

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users