Jump to content


Photo

Population PK troubleshooting

population pk nlme

  • Please log in to reply
1 reply to this topic

#1 csheme

csheme

    Advanced Member

  • Members
  • PipPipPip
  • 59 posts

Posted 04 November 2018 - 06:32 PM

Hi, 
 
I can not get my popPK model to run, and am requesting troubleshooting support. Please see my attached model with intravenous infusion input. It seems to get to 1000 iterations and then crashes on me. When I converted the dosing to match the units of my observations, the model crashes. Could you please help me troubleshoot my model. 
 
Thank you.
 
 
 
I did further troubleshoot, what I did was used a reduced no. of subjects from the original dataset to test the model. 
 
Once this was successful, then I used the same input and structure into the full model with full number of subjects.
 
I really have no idea what is going on, I checked the units for infusion, dosing and rate, they are the exact same in both datasets. 
 
What could be causing such a discrepancy in the 2 fits from the 2 models below? Does NLME have a limit to how many patients can be assessed? 
 
The fit on the right looks shifted 1000-fold for IPRED, what could be going on here, again the dosing input is identical. 
 
Something seems to be very buggy,
 
2s84pjc.png

Edited by csheme, 05 November 2018 - 10:48 PM.


#2 cradhakr

cradhakr

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 06 November 2018 - 02:28 PM

Hi,

 

The error you are getting could be due to the initial estimates. Therefore, enabling MAP-NP start option in Run options tab could refine the bale and will successfully converge.

 

Reducing the subject no makes the objective function value (-2LL) change and converge to different final estimates. Also, there are no limits to the patient no using NLME.







Also tagged with one or more of these keywords: population pk, nlme

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users